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Overview  
Planar cell polarity is the systematic organization of cells in biological tissue, usually of epithelial origin, 

where cells exhibit coordinated directionality that arises due to a number of developmental factors. 

Planar cell polarity is an integral identity aspect for some cell types (e.g. cochlear hair cells, vestibular 

hair cells, fly ommatidia, etc.) and is required for proper functioning on an inter- and intracellular level. 

For investigators interested in planar cell polarity, the quantification of cellular direction is a tedious task 

where investigators must often manually draw directional arrows on every cell in a sample field. We 

have developed a Fiji (Fiji is Just ImageJ)[1] based plugin that automates the process of cell polarity 

measurements, called PCP Auto Count (PCPA).  

Because planar cell polarity directional indicators differ by tissue type, we have elected to use 

generalized descriptive terms to explain the development and functioning of PCPA. Large planar 

surfaces (often the apical surface of a cell) are hereafter called “chunks'' while prominent inclusions 

indicative of direction, often representative of cilium or groups of cilia, are hereafter called “caves.” 

These chunk and cave configurations may also arise from combinations of various features, including the 

morphology of the cell or feature of interest (e.g. v-shaped features such as filiform papillae of the 

tongue or stereocilia bundles of mammalian outer hair cells).The following explanation guide provides 

examples using inner ear cochlear hair cells and vestibular hair cells. To visualize the cells’ apical 

surfaces and find the directional indicator for each hair cell (called a fonticulus), we have elected to use 

βII-spectrin staining, which will bind to the spectrin-rich cuticular plate of a hair cell while leaving the 

actin-rich kinocilium unlabeled. The resulting immunohistochemistry produces the spheroid shape of 

the cell with staining absent from the kinociliar area. Validation of PCPA on other tissues, cell types, and 

staining methods is reported in Stansak et al. (2024; in prep). Our results suggest that PCPA should have 

broad applicability for any users who wish to measure the directionality of any cells or structures that 

adhere to a “chunk and cave” morphology. Readers are directed to consult Stansak et al. (2024; in prep) 

for additional information.   

The goal of PCPA is to first identify cells in binary images, usually photomicrographs, then apply 

algorithmic processes to determine directionality for cells meeting user defined selection criteria, thus 

allowing for automated calculation of planar cell polarity angles. To accomplish this, PCPA identifies all 

white pixels in an image and creates grouped aggregates of adjoining pixels. User defined exclusion 

criteria is used to filter out artifact pixels and the remaining pixel aggregates are designated as regions 

of interest. While aggregates in the images herein generally represent “cells”, other features of interest 

may be used in planar cell polarity studies, and other users may have non-biological images from which 

they seek to determine the orientations of certain features. Thus, we have elected to refer to 

aggregated pixel groups as “chunks.” After the identification of chunks, the algorithm will then identify 

black pixels within the bounds of the chunk which we have termed “caves”. PCPA will then assign the 

cave that best meets its user defined selection criteria as the directional cave of interest. An angle 

measurement (in degrees) is then calculated for each chunk by projecting a ray originating from the 

center of the chunk to the center of the cave.  
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Software requirements and plugin installation 

Required software:  
Fiji (Fiji is Just ImageJ), available from: https://imagej.net/software/fiji/ 

PCPA operates as a plug-in within the existing open-source image processing software, Fiji (Fiji is Just 
ImageJ)[1]. FIJI is compatible with Windows, MacOS, and Linux operating systems. More information 
about Fiji can be found at the link above.    

Plugin installation: 
1. Open Fiji  
2. Select “Help > Update…” 
3. Select “Manage Updated Sites” 
4. Select “Add Unlisted Site” 
5. Enter the following information into the new line-item’s corresponding columns (without 

quotations) 
a. Name: "PCP Auto Count" 
b. URL: “https://sites.imagej.net/PCP-Auto-Count/” 

6. Select “Apply and Close” 
7. Select “Apply Changes” 
8. To finish installation please restart Fiji 

a. The PCP Auto Count menu will be found under “Analyze > PCP Auto Count” 
b. The stand-alone rose diagram plugin will be found under “Plugins > Utilities > Rose 

Diagram” 
 
 

Validation of the PCPA plugin suite has been published in Stansak et al. (2024; in prep) 

 
PCP Auto Count is an open-access plugin. Source code can be found at  

https://github.com/WaltersLabUMC/PCP-Auto-Count.git 

A video demonstration of PCPA can be found at https://youtu.be/PTFlGv5Laa0 

 

 
 
 
 
 
 
 

 

 

https://imagej.net/software/fiji/
https://sites.imagej.net/PCP-Auto-Count/
https://github.com/WaltersLabUMC/PCP-Auto-Count.git
https://youtu.be/PTFlGv5Laa0
https://youtu.be/PTFlGv5Laa0
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Required image parameters:  
● A minimum image resolution of 1024 pixels along the longest edge of the image is strongly 

recommended for good performance when using images that contain approximately 10 – 100 
cells 

● For images that are at lower resolution, users can try resizing images in Fiji through the 
following menu pathway: “Image > Adjust > Size…” 

● Note that while such size adjustments were generally beneficial in our development and 
validation testing of PCPA, images that have been resized may have artifacts or pixel 
mean gray values that may alter PCPA performance. 

● A two-dimensional, binary (i.e. black and white pixels) image 
● Pre-processing steps which we have found to benefit PCPA performance on micrographs 

of inner ear tissues (e.g. thresholding) may not work on RGB, CMYK, or other color 
composite images. 

● Instructions on converting color images to grayscale and/or binary are explained in the 
“Image Pre-processing” section below. 

● File type 
● While PCPA will run on any images that can be opened with Fiji, images should be saved 

at the time of acquisition as a file type that prevents data compression. Most inbuilt 
microscopy software defaults to save images in lossless format (e.g. CZI, ICS, OME-TIFF, 
LIF, ND2, etc.). Other lossless formats such as TIFF, PNG, and BMP are also acceptable.  

● JPEG and other formats that alter resolution or compress are not recommended 

Recommended imaging parameters:  
● We have found that PCPA works most effectively on micrographs acquired using a 40X or higher 

primary objective lens. Samples imaged at lower objective magnification may or may not have 
sufficient detail to convert well to binary images and users should use their best judgment based 
on their specific images and experimental goals.    

● Image acquisition tips:  
● High signal-to-noise ratio antibody labeling is desirable 
● Samples used to demonstrate PCPA utility in this manual were immunolabeled with βII-

Spectrin and were imaged to make the βII-Spectrin positive cellular features as bright as 
possible, such that nearly all of the pixels that comprise each chunk are at the level of 
complete saturation. 
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Image Pre-processing 
The PCP Auto Count plugin requires users to convert their images to binary (i.e. all pixels are assigned 1 

of 2 values: black or white). Several preprocessing steps are recommended to create a binary image with 

sufficiently removed background. Depending on staining practices, imaging parameters, and type of 

sample used, each user will need to decide which preprocessing steps result in the best binary images to 

use with the PCP Auto Count plugin.  

Below are recommended preprocessing steps which can be carried out using existing functions within 

FIJI (Fiji is Just ImageJ). Each step includes a brief explanation of purpose and function, plus a few listed 

alternatives. This guide is not meant to be an exhaustive list of preprocessing measures users may take, 

rather, a starting point which showcases Fiji features our laboratory has used to generate binary images 

from several types of biological samples as reported in Stansak et al. (2024; in prep). Users are 

encouraged to develop a preprocessing protocol that works best for their project goals. All example 

images in the following guide were obtained using a Zeiss LSM 880 confocal microscope with a 40X or 

63X oil immersion objective at 2048 x 2048 pixel resolution.  

Step 1: Flatten z-stack and crop image.   
PCPA is designed to work on two dimensional images. If a z-stack or time-series set of images are 
contained within the same window, PCPA will only analyze the window that is visible at the time the 
plug-in is run. Users are therefore advised to generate a 2D projection image from their z-stack and 
ensure images are grayscale or monochromatic. The easiest way to check if an image is monochromatic 
is to select “Image > Type” and verify your image is set as 8-bit. Crop out extraneous areas of the tissue 
which will not be quantified (Fig 1A-1B).  

Image preprocessing, particularly the thresholding step necessary for creating binary images, works best 
for images where the mean gray value (i.e. intensity or “brightness”) is relatively uniform across the 
image. In the case of cochlear samples used for illustrative purposes in this manual, we found that 
cochlear inner hair cells (IHC) showed significantly brighter fluorescence for our protein of interest (βII-
Spectrin) than cochlear outer hair cells (OHC). The signal difference between the cell types caused issues 
during the thresholding step; to address this we cropped our image to analyze IHC and OHC  

Optional steps:  

● For images with low signal-to-noise ratios, Fiji’s enhance contrast (“Process > Enhance 
Contrast…”) may help. Otherwise, manual adjustments to brightness and contrast may also be 
beneficial. 

● Selecting Equalize histogram will spread pixel intensities over a broader range and also decrease 
spread between brightest and dimmest pixel intensities. This differs from using linear contrast 
enhancements (Image > Adjust > Brightness/Contrast), which will alter spread of pixel values but 
does not affect relative pixel value in relation to brightest and dimmest pixels.  

● Spherical aberration caused by microscope lenses can lead to decreased fluorescence intensities 
for features near the edges of the field of view. The Pseudo Flat Field Correction tool available in 
the BioVoxxel Toolbox (www.biovoxxel.de) plug-in for Fiji/ImageJ 
(https://imagej.net/plugins/biovoxxel-toolbox) can help normalize signal-to-noise ratio across 
the image  

http://www.biovoxxel.de/
https://imagej.net/plugins/biovoxxel-toolbox
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Step 2: Remove background signal.  
Removal of background signal can be accomplished in several different ways using inbuilt Fiji 
functionality or Fiji plug-ins.  

● Recommended: Fiji’s Subtract Background (“Process > Subtract Background…”; Fig 2) 
● Subtracts background using a rolling ball radius to remove background staining while 

preserving low intensity pixels.  
● Alternative: If your image has high variability of fluorescent intensity between cells that is not 

sufficiently addressed using Fiji’s subtract background function, users may wish to try more 
nuanced background subtraction applications, such as the Biovoxxel toolbox plugin for Fiji 
(www.biovoxxel.de; Discussed in Step 1) which features a convoluted background subtraction 
feature that increases contrast by subtracting a modified filter from the entire image. 

● The convoluted background subtraction tool is heavily recommended over Fiji’s Subtract 
Background if users applied Biovoxxel’s Pseudo Flat Field Correction to adjust for 
spherical aberration (discussed in Step 1 optional steps). 

Step 3: Threshold image and make binary.  

Fiji’s threshold feature allows users to select what pixel intensity defines the cutoff boundary for 
creating a binary image. The selected pixels will be assigned a value of 1 (“white”) and all pixels not 
selected will be assigned a value of 0 (“black”). Choose one of the following methods, or a comparable 
method of the user’s choosing. 

● Recommended: Fiji’s Manual Threshold Selection (“Image > Adjust > Threshold…”) 
● This method gives users greater control than Fiji’s Auto Threshold function. User 

generated threshold selection is recommended when signal-to-noise ratios and image 
quality vary across sample images in a data set.  

● Users should adjust the threshold bar to incorporate as many cells as possible, while 
preventing cells from dilating to the point of touching surrounding cells (Fig 3A, 3A’, & 
3C). PCPA has a limited ability to “separate” two cells that touch but this function 
cannot account for more than two cells touching (See: “Doublet Splitting” in the “PCPA 
workflow and algorithm” section of this document).  

● Users should also ensure the directional point of interest is not obliterated during the 
thresholding process (Fig 3C). A directional point of interest that is not completely 
enclosed by the cell body can be addressed using user features outlined below (See: 
“Plastic Wrap” and “Cave Size Exclusion” sections in the “PCPA workflow and algorithm” 
section of this document) 

● Alternative: Fiji’s Auto Threshold function: “Image > Adjust > Auto Threshold” 
● Auto threshold works best on images with high signal-to-background ratios that are 

consistent across the entire image. Users may choose any type of auto threshold 
method which best compliments their images, but for the purpose of this document the 
method is selected as Default (Fig 3B & 3B’).  

Step 4: Remove outlier pixels.  
Fiji’s Remove Outliers function examines each pixel and converts it to the median color of the 
surrounding pixels in a user defined radius. This function is useful for removing small pixels or groups of 
pixels that are remaining artifacts left after the thresholding function is performed (Fig 4). 

● Recommended: Fiji’s Remove Outliers “Process > Noise > Remove Outliers…”  

http://www.biovoxxel.de/
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● Optional: Fiji’s erode function (“Process > Binary > Erode”).  
● The erode function removes a small number of pixels from the edge of objects in a 

binary image. This can be useful for images where cells touch their neighbors after 
thresholding the image (Fig 5). 

● Optional: Fiji’s dilate function (“Process > Binary > dilate”) 
● The dilate function adds a small number of pixels to the edge of an object in a binary 

image. This function can be useful for samples where small holes occur after 
thresholding the image due to uneven staining intensity within a cell.  
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Brief overview of PCPA workflow and algorithmic processes  
The general algorithmic processes used by PCPA are described below, in order of operation used by 
PCPA during analysis (Fig 6). All steps marked as optional are dependent on whether or not a user 
selected the setting prior to running PCPA. If no user settings are indicated for a step marked optional, 
PCPA will skip that step and continue on to the next process in its workflow. Optional steps are 
explained in terms of theory in this section. To see user options explained in practical terms, please see 
the User Options Guide chapter.   

Chunks are identified 
PCPA processes pixels on a Cartesian (x, y) coordinate system where the topmost, leftmost pixel in the 
image is assigned the coordinates (0, 0) with x values increasing left to right and y values increasing top 
to bottom. PCPA will begin parsing pixels starting from the top of the first column (coordinates: 0, 0) and 
subsequently descend the column until it encounters a white pixel or the image border is reached and 
the column terminates (Fig 7A). If PCPA encounters any white pixels in Column 0, PCPA records the XY 
coordinates and moves down the column to the next pixel. If the next pixel is also white PCPA will 
categorize the XY coordinates of the two touching pixels as belonging to the same group which we have 
termed a “chunk”. Abutting white pixels will continue to be added to the same chunk until PCPA 
encounters a black pixel, in which case the chunk is considered complete for that row and the next 
white pixel encountered in the column will become the start of a new chunk (Fig 7B). At the termination 
of Column 0, all subsequent columns will be evaluated in the following manner: PCPA will descend from 
the top of the column until it encounters a white pixel or the image border is reached and the column 
terminates. In the case of encountering a white pixel, PCPA will check if the pixel abuts a white pixel in 
the column directly to its left (Fig 7C & 7D). If so, the pixel of the current column will be assigned to the 
chunk from the previous column (where: end1 >= start2 and end2 >= start1). If the pixel in the current 
column does not abut a white pixel to its left, then PCPA will create a new chunk designation This 
operation will recurse until PCPA has evaluated all columns in the image.  

Optional step: Exclude chunks by size.  
If users have set minimum or maximum size exclusion settings for chunks, PCPA will use these 
parameters to exclude all chunks that meet exclusion criteria from subsequent processes (Fig 8A & 
8A’).    

Optional step: Doublets/oblong chunks are split or excluded.  
Natural biological variability, insufficient magnification during imaging, and a variety of other factors can 
cause instances of cells crowded into close proximity. In mouse models, for instance, outer hair cells 
stained with βII-spectrin do not tend to overlap or touch, whereas inner hair cells typically have less 
space between cells, causing oversaturated pixels to touch. PCPA has a limited ability to separate a 
maximum of two cells that overlap. These user options are not able to recurse beyond splitting a 
“doublet” of cells. Users can set a threshold ratio to detect doublet cells by specifying a ratio of chunks 
that are taller than they are wide, and/or chunks that are wider than they are tall. If a chunk meets 
doublet criteria PCPA will encase the chunk in a bounding box, then split the bounding box down the 
middle, where direction of splitting will be based on whether the chunk violates “taller-than-wide” 
(horizontal split) or “wider-than-tall” (vertical split) criteria (Fig 8B-8B’’). Once a doublet is split into two 
boxes, PCPA will then treat all pixels contained within each box as an independent set and apply user-
defined chunk and cave criteria to pixels within each of the boxes. While PCPA is unable to split more 
than two merged chunks, PCPA user settings allow for size exclusion criteria to be applied (either 
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separately or in conjunction with Doublet Splitting) so that users are able to exclude large 
conglomerates of merged chunks from further analysis.  

Optional step: Exclude chunks near the image border. 
Removing chunks a set number of pixels from the image border allows the user to filter out cells that 
were not completely captured within the microscope’s field of view during image acquisition. As the 
center of mass of a chunk is used to determine the angle of orientation, it is generally wise to exclude 
chunks at the image border which may have a distorted center position due to cropping. This setting 
creates an exclusionary border around the outer edge of the image and any chunk, regardless of size, 
touching this exclusion zone will be filtered out of subsequent steps (Fig 8A & 8A’).  

Optional step: Plastic wrap 
PCPA defines “caves” as all aggregates of black pixels that are fully contained within the body of a chunk 

(i.e. completely surrounded by white pixels constituting the chunk). Depending on cell morphology and 

imaging quality, it is possible that true directional markers may not be fully enclosed within the cell 

body, and thus could be incorrectly ignored by PCPA’s definition of “cave.” If PCPA cannot find a cave 

that meets selection criteria, the chunk will be excluded from subsequent PCP analysis.  

In order to overcome this limitation, we have developed a feature called Plastic Wrap, which is included 

in PCPA’s user options menu. To begin Plastic Wrap, PCPA draws a square or rectangular box that 

encompasses all pixels of the chunk, termed a bounding box. Starting at the lowest value coordinates (0, 

0) of the bounding box, PCPA scans Row 0 from left to right until it encounters a white pixel. PCPA then 

checks directly to the right of the beginning pixel for an adjacent white pixel. If encountered, the 

abutting pixel is added to the plastic wrap coordinates. PCPA will continue chaining white pixels that 

abut to the right of the previous pixel until PCPA detects an orphan pixel (i.e. a white pixel with no 

abutting white pixel in the current scanning direction). In this case, the algorithm will attempt to find the 

nearest white pixel by plotting an exploratory line from the orphan pixel to the last column of Row 0, 

using slope intercept formula. If no white pixels that are part of the chunk being assessed fall within the 

exploratory line, PCPA will next plot an exploratory line from the orphan pixel to the last column of Row 

1. This pattern will recurse down the rows of the last column until PCPA encounters a white pixel of the 

chunk that falls within the exploratory plotted line. PCPA will then include the found pixel as the end of 

the exploratory line, and any part of the line that bridges the gap between the starting pixel and the 

terminating pixel will be added to the pixel mass. The terminating pixel now becomes the end of the 

chain, and PCPA will continue using a similar strategy as outlined above to either add abutting pixels to 

the chain or designate a new orphan pixel at the end of the chain. In the case of an orphan pixel, PCPA 

again sends out an exploratory line, which will now start at the last column of the orphan pixel’s row, 

rather than start at the last column, row 0 (Fig 9B-E). Connecting orphan pixels to terminal pixels in an 

exploratory line occurs in the same manner as described above (Fig 9F).  

Plastic Wrap will continue in a similar fashion until it encounters an orphan pixel that directly abuts the 

bounding box. Next, PCPA will change its chaining strategy from moving across row 0 to moving down 

the last column, following a similar manner as described above, and again terminate when the orphan 

pixel abuts the bounding box. Then, PCPA will move across the bottom row from left to right, following a 

similar manner as described above, and again terminate when the orphan pixel abuts the bounding box. 

Finally, PCPA will move up Column 0 from bottom to top, following a similar manner as described above. 

Once Plastic Wrap has connected the last orphan pixel to the pixel that began the Plastic Wrap chain, 
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the operation is finished. All pixels added as part of joining an orphan pixel and a terminal pixel are 

considered as part of the chunk mass for all subsequent calculations (Fig 9G). In this way, indentations in 

chunks can become fully enclosed caves and directionality can be determined from the most prominent 

indentation in a chunk (or the indentation that most closely aligns to the user specified direction). 

Chunk centroids are calculated  
The centroid of each chunk is calculated using the same programming logic as Fiji Image J’s center of 
mass function, which calculates the average of the X and Y coordinates of all pixels in the chunk. The 
chunk centroid value is used as the vertex for planar cell polarity calculations of each cell.  

Cave candidates are identified  
PCPA will perform a similar operation as described in the chunk identification section to locate all caves 
within each chunk and record their (x, y) coordinates . To be recognized as a “cave,” inclusions of black 
pixels must be enclosed within the body of the chunk (this includes black pixels enclosed by using the 
Plastic Wrapping user option).  

Optional step: Exclude caves by size  
If users have set minimum or maximum size exclusion settings for caves, PCPA will use these parameters 
to exclude all caves that meet exclusion criteria from subsequent processes 

Cave selection criteria is applied 
In the absence of user input for cave exclusion size and cave directionality, PCPA will assign the largest 

cave as the cave of interest for subsequent planar cell polarity calculations. While the majority of users 

will be best served by setting the cave of interest selection criteria as largest cave, we have afforded 

users the option to apply a directionality filter (northmost, southmost, westmost, easternmost, highest 

position, lowest position, leftmost position, or rightmost position) to the cave selection process. 

Whichever cave best meets the largest cave criteria, or user-defined direction criteria, will be designated 

the cave of interest for the chunk (Fig 10). 

Cave centroids are calculated  
The centroid of each cave is calculated using the same programming logic as Fiji ImageJ’s center of mass 
function, which calculates the average of the X and Y coordinates of all pixels in the cave of interest. The 
cave centroid value is used as the point the ray is drawn through for planar cell polarity calculations of 
each cell.  

Planar cell polarity is calculated and data is output  
The values obtained for the centroid of the chunk and the centroid of the cave are used to calculate the 
inverse tangent of the slope of the line that connects these two points, and this value is used to draw 
directional arrows on the output image. The inverse tangent of differences in x and y is used to 
determine the angle measurement in degrees for each cell. Users can customize the reference for angle 
measurements by setting the axis scale (-180 ° /180 ° or 360°), axis direction (clockwise or 
counterclockwise) and direction of 90° axis (north, south, east, or west). The following summary 
statistics (based on calculations from Fisher [2]) are calculated for the angle measurements and 
presented as a results table (Fig 14):  
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User options guide 
To set processing parameters and PCPA output options, users should select the following Fiji menu 
pathway: “Analyze > PCP Auto Count > Measure With Options…”. Detailed explanations of the PCPA 
options menu are found below. PCPA will remember last user settings applied and for subsequent uses, 
if the user does not wish to change any options, users may select “Analyze > PCP Auto Count > Measure 
Now.” It is recommended that users familiarize themselves with the tools provided below in order to 
maximize accuracy of PCPA measurements.  

Exclude chunks by size (Fig 11A) 

Under the “Chunk Detection” tab, users can set size exclusions to disregard chunks falling above and/or 

below a specified number of pixels by entering values in “Remove noise of this many pixels or fewer” 

and/or “Remove ‘conglomerates’ of this many pixels or more” fields. Chunks removed from further 

analysis via minimum or maximum size exclusions can be optionally indicated on the output image with 

pseudocoloring (see output description below and Fig 11A’).  

To set a minimum size requirement, users will select the checkbox then enter a numerical value into the 

“Remove noise of this many pixels or fewer” field. Fairly low minimum size requirements will remove 

noise (i.e. lone white pixels or small aggregates of pixels) similar to preprocessing steps outlined in the 

preprocessing section of this manual. Larger minimum size requirements can be set to exclude objects 

that are not cells or features of interest. Validation with mouse hair cell micrographs suggests a 

minimum size requirement to approximately 33% of the size of your average cell size will filter out 

irrelevant aggregates from most images, and values ~ 50-75% of the size of your average cell can allow 

investigators to filter out immature or fragmented cells (Fig 11A). Setting a maximum size requirement is 

achieved by selecting the checkbox then entering a numerical value into the “Remove ‘conglomerates’ 

of this many pixels or more” field.  

Exclude chunks near the image border (Fig 11A)  
Under the “Chunk Detection” tab, users may optionally set an exclusion zone near the image border to 
filter out cells that were incompletely captured by the microscopy field of view (Fig 11A). Users may find 
a small (e.g. 1-10 pixel) exclusion zone to be sufficient for excluding incompletely imaged cells, though 
cropping, resizing, or reorienting of images may require larger values. Border excluded cells can be 
optionally indicated on the output image with pseudocoloring (Fig 11A’).  

Doublets/oblong chunks are split or excluded (Fig 11B) 
Users should endeavor to avoid allowing cells to touch during the thresholding preprocess. However, 
PCPA does contain limited ability to address merged chunks (termed “doublets”), though this operation 
is not able to address instances where more than two cells touch. Under the “Chunk Detection” tab 
users have the option to split chunks by setting a ratio of wider-than-tall and/or taller-than-wide. 
Depending on settings used, PCPA will split the doublet vertically or horizontally, respectively, into two 
equally sized cells that are each treated as independent chunks for further processing steps (Fig 11B’). 
Users may alternatively choose to exclude doublet chunks from further analysis. It is important to note 
that the success of the doublet splitting is optimal when the orientation of the doublet is vertical or 
horizontal; accuracy of doublet splitting decreases as the orientation of the doublet approaches a 45°, 
135°, 225°, or 315° axis. If triplets or larger conglomerates of cells are present, Doublet Splitting is no 
longer possible and users should apply maximum size exclusion criteria (explained above) to remove 
conglomerates  
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Plastic wrap (Fig 12) 
While PCPA was initially developed to detect fully enclosed caves, such as what is commonly seen in βII-
spectrin labeled hair cells, biological and experimental variability often led to images with cells that did 
not have a “cave” that was completely enclosed by white pixels (Fig 12A’). Furthermore, a wide array of 
sample types in planar cell polarity studies have morphology more consistently described as 
indentations rather than holes.  

In default mode, a chunk will be excluded from subsequent analysis if PCPA cannot find a cave that is 
not fully enclosed. PCPA has an optional, but recommended, feature called Plastic Wrap which will 
enclose concave features by following the perimeter of the cell and adding white pixels to bridge any 
gaps in the arc of the cell’s perimeter. Under the “Cave Detection” tab, users should select the box 
labeled “Apply Plastic Wrap to chunks before cave detection” to use the Plastic Wrap feature (Fig 12A).   

Exclude caves by size (Fig 12)  
For any chunks that are not smoothly rounded (or perfectly rectilinear) there will often be a variety of 
small, concave inclusions of black pixels. The noise removal step described above in image pre-
processing often removes many of these. However, persistent inclusions can be filtered out of the cave 
selection process by setting a lower size limit for cave selection (Fig 12B). Conversely, cell types that lack 
a common geometrical shape (such as is seen in basal cochlear cells which resemble a boomerang or 
horseshoe shape) can cause large artificial caves to be created during the Plastic Wrapping process. To 
control for this, users can also set an upper size limit for cave selection under the “Cave Detection” tab 
(Fig 12B). 

Cave selection criteria applied (Fig 12)  
PCPA’s default mode is to assign the largest cave that does not exceed optionally set size limits as the 
cave of interest for subsequent planar cell polarity calculations. While the majority of users will be best 
served by setting the cave of interest selection criteria as largest cave, we have afforded users the 
option to apply a directionality filter to the cave selection process, found under the “Cave Detection” 
tab. The directional options are: northmost, southmost, westmost, easternmost, highest position, 
lowest position, leftmost position, or rightmost position (Fig 12C). The compass directions are 
determined using the angle calculation of the chunk and potential cave centroids whereas the body 
relative directions (leftmost, etc.) are determined using x or y values of the potential caves only. These 
directionality features should be used with minimum cave size requirements so that incidental 
inclusions that may best match directionality settings are discarded (Fig 12C’). 

Orientation of angle measurements (Fig 13) 
Under the “Angle Measurements” tab, users can choose the orientation of the axis used to create PCP 
measurements. This allows users to standardize orientation across images by measuring all images on 
the same axis, or to customize the axis for each image measured. The latter approach allows users to 
standardize data collection across a variety of images that are not in the same anatomical orientation, 
without manually rotating the images prior. Users can customize how angle measurements are 
calculated by setting the axis scale (-180°/180° or 360°), axis direction (clockwise or counterclockwise) 
and direction of 90° axis (north, south, east, or west; Fig 13).  

Customizable data output (Fig 14)  
Under the “Output” tab, users can select which output boxes they wish to view after PCPA is ran. The 
output options include:  

● Results Table 
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● Label: number assigned to a specific cell 
● Chunk Centroid X: chunk centroid coordinates on the X-axis, calculated as: 

 
● Chunk Centroid Y: chunk centroid coordinates on the Y-axis, calculated as: 

 
● Cave Centroid X: cave centroid coordinates on the X-axis, calculated as: 

 
● Cave Centroid Y: cave centroid coordinates on the Y-axis, calculated as: 

 
● Vector length: square root of distance between chunk centroid and cave centroid 
● Angle°: PCP angle measurement (in degrees), calculated as the inverse tangent of the 

slope between the chunk centroid and cave centroid 
● Chunk Summary 

● Processed Count: count of successfully analyzed chunk-cave pairs 
● Bad Count: count of chunks that were excluded from PCP angle calculations due to 

violating set size parameters or because they did not have a recognizable cave. 
● Total Count = Processed Count + Bad Count 
● Processed %: chunks processed as a percentage of total chunks   
● RML: Root mean resultant length 
● Variance 
● Mean Angle 
● Standard Deviation 

● Rose diagram 
● Overlay: contains cell label, angle measurement, and directional line. Each aspect of the overlay 

can be optionally removed (Fig 14B). The overlay can be superimposed over the original image 
(“Image > Overlay > Add image…” select “zero transparent”) to allow investigators to view the 
planar cell polarity line, label, and/or angle on the original image.  

● Arrows: directional arrows 
● Labels: number assigned to a specific cell; corresponds with chunk summary table 
● Angles: calculated angle of chunk-cave pair (in degrees) 

● Image: the image fed into PCPA with overlays for various characteristics, including chunk label, 
angle measurement, directional arrow, Plastic Wrap, doublet splitting, and color coding of 
excluded chunks (Fig 14D). Color coding can be customized for accessibility under the “Colors” 
tab (Fig 14E). 
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Other PCPA functionalities 

Counting of cells when researchers do not need PCP information 
If users wish to count cells, but do not need or wish to view PCP angle measurements, Users will 
proceed in a similar manner as if they wished to obtain PCP angle measurements. On the PCPA user 
options menu, users should still set chunk size exclusions, split doublets, and exclude cells on the image 
border as needed for their images. It is not necessary to use Plastic Wrap. On the “Output” tab, we 
recommend selecting “Chunks Summary,” “Overlay,” and “Image” outputs (Fig 15A-B). For “Overlay 
Options” select “Labels.” PCPA will then analyze the image as if it were collecting PCP information, 
including excluding chunks it cannot find a cave for. The output for the Chunk Summary table will then 
show how many cells had PCP angle measurements calculated ( “Processed Count”) and how many cells 
did not have angle measurements calculated (i.e. chunks lacking a cave; “Bad Count”) (Fig 15C). To 
obtain total cell count (sum of “Processed Count” and “Bad Count”), users should refer to the “Total 
Count” value. All data fields beyond “Total Count” are related to PCP information, and can be ignored if 
only the cell count is desired. Please note that chunks excluded for violating chunk size requirements or 
border proximity are not included in the “Bad Count” or “Total Count” value. 

PCP Auto Count plugin batch processing (analyzing multiple images together)  
PCPA can analyze multiple images together (batch processing). This option considers each image of the 
batch to be a continuous set of data and all output metrics will be calculated based on data aggregated 
from all batched images. To batch process multiple images, open all desired images in Fiji then select 
“Analyze > PCP Auto Count > Measure All Open Images With Options…” if the user wishes to change any 
processing or output options for PCPA (Fig 16). If users wish to batch process images using last used 
settings, select “Analyze > PCP Auto Count > Measure All Open Images Now…” 

Rose Diagram generation of non-PCPA data  
Included in the PCPA package is an option for users to generate a rose diagram and summary statistics 
using data provided by the user. This action is independent from running PCPA data, so users can create 
rose diagrams and summary statistics tables from any circular data they wish (Fig 17). To use the stand-
alone rose diagram function, select “Plugins > Utilities > Rose Diagram. Users can then enter or paste 
angle measurements into the input box, as one angle per line. Users are given options to input the axis 
orientation used for the data set, and to customize the rose diagram bar size and angle markers. Users 
may also obtain summary statistics (root mean length, variance, mean angle, and standard deviation) for 
the data set by checking the box for Angle Summary 
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Figures 

 

Figure 1. Image acquisition and field of view cropping. (A) Maximum intensity projection of z-stack 

images from P4 cochlea (63X oil immersion objective; 2048 dpi; 8-bit). (B) The original image was 

cropped to include only IHC and OHC. (C-D) The outer hair cells and inner hair cells were saved as 

separate images and preprocessed separately.  
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Figure 2. ImageJ’s Subtract Background function. (A) Original cropped image of P4 cochlea (63X oil 

immersion objective; 2048 dpi; 8-bit). (B) P4 cochlear image after applying a 50-pixel rolling ball radius 

background subtraction with sliding paraboloid.  
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Figure 3. Threshold image to make binary. (A) To use the Manual Threshold function, users should use 

the top bar (green arrow) to adjust the amount of thresholding applied (appearing as red pseudostaining 

in the open image). Users should set the threshold to maximize inclusion of cell mass pixels while 

minimizing inclusion of background staining. (A’) Binary image created by Manual Threshold function. 

(B) Fiji ImageJ features an Auto Threshold option with various in-built thresholding methods. Auto 

Threshold may be useful on well imaged samples with minimum background staining. (B’) Binary image 

created by Auto Threshold function (default method). (C) Whatever approach chosen, users should 

endeavor to prevent threshold levels that cause cells to dilate to the point of (C’) touching surrounding 

cells.  
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Figure 4. ImageJ’s Remove Outliers function. (A) E17.5 utricle (40X oil immersion objective; 2048 dpi; 8-

bit) after background subtraction. (B) Image after manual thresholding, with accidental inclusions of 

background staining. (B’) Subset of B, showing pixels near the bottom of the cell (yellow arrow) that may 

cause PCPA’s plastic wrap function to create an incidental cave that could interfere with correct angle 

calculations. (C) Fiji ImageJ’s inbuilt remove outliers function allows users to remove outlier pixels via by 

a user defined pixel radius. (C’) Subset of C, showing cell after removing outlier pixels (radius: 5 pixels; 

threshold 50) from the image. 
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Figure 5. ImageJ’s erode function. (A) P4 cochlear hair cells (63X oil immersion objective; 2048 dpi; 8-bit) 

original image. (B) After manual thresholding of the image, two cells touch (yellow arrow). Left 

unaddressed, this will cause PCPA to categorize the two cells as one long cell and subsequently produce 

incorrect angle measurements for this doublet. (C) After applying 2 iterations of ImageJ’s erode function 

the cells no longer touch.  
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Figure 6. Overview of PCPA’s algorithmic flow. (A) PCPA identifies aggregates of white pixels in a binary 

image, termed chunks. (B) Chunks can be discarded from subsequent operations via an optional pixel 

size minimum and/or maximum. (C) PCPA has limited (maximum of two adjacent cells) capacity to 

separate (or exclude) chunks that touch as a result of the thresholding process during pre-processing. 

(D) Cells that fell partially outside of the imaging frame can be discarded by setting an exclusion zone of 

a set number of pixels away from the edge of the image frame (cells pseudo-colored blue). (E) In the 

absence of Plastic Wrap, fonticuli that are not completely enclosed in β-spectrin staining cannot be 

recognized by PCPA. Applying Plastic Wrap will add pixels to bridge the gap in the cell’s perimeter where 

the unenclosed fonticulus would be. (F) The center of the chunk’s mass is calculated. (G) The cave best 

meeting selection criteria is identified as the directional cave of interest. (H) planar cell polarity is 

calculated using the chunk centroid as the vertex and the cave centroid as the ray node indicating 

directionality. (I) PCPA outputs include annotated images specifying chunks excluded due to violating 

chunk size limits (cells pseudo-colored pink) or touching the border of the image (cells pseudo-colored 

blue). Cells are labeled in the annotated output and correspond with the angle results table, which 

proves a detailed output of summary statistics for each chunk that was quantified. Rose diagrams and 

summary statistics tables (not shown) are also produced. 
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Figure 7. Example image demonstrating how PCPA identifies pixels of interest. (A) PCPA scans down 

column rows to find white pixels. At the end of each column, PCPA recurses and begins again at the top 

of the next column. (B) If PCPA encounters a white pixel it will determine if the white pixel abuts any 

other white pixels in its current column or the column to its left. If it does not, a new pixel aggregate 

called a chunk is recorded. (C-D) If white pixels in the current column abut any white pixels to their left, 

all of these pixels will be assigned to the same chunk.  
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Figure 8. (A) Example of a border exclusion zone (red). (A’) Any chunks that meet size exclusion criteria 

are excluded from subsequent analysis (pink). Any pixels that touch or fall within the exclusion zone will 

be excluded from subsequent analysis (blue). Note that because the size exclusion step occurs before 

the border exclusion step, some chunks that would otherwise violate the border exclusion step have 

already been disregarded from analysis by the size exclusion step, and are thus categorized under size 

excluded chunks instead of border excluded chunks. (B) Thresholded image featuring two cells that 

touch. (B’) Subset of touching cells from A. If no doublet splitting options are applied, PCPA will treat this 

chunk as one mass and the angle measurements will incorrectly calculate based on the total chunk mass 

and dominant cave of the chunk. (B’’) Doublet splitting settings recognize this chunk as a doublet, draw 

a bounding box (yellow), then split the bounding box in half (orange). The two resulting halves will be 

treated as independent chunks with chunk and cave centroid calculations being based on the mass 

contained within each respective box. (B) Example of a border exclusion zone (red). (B’) Any chunks that 

meet size exclusion criteria are excluded from subsequent analysis (pink). Any pixels that touch or fall 

within the exclusion zone will be excluded from subsequent analysis (blue). Note that because the size 

exclusion step occurs before the border exclusion step, some chunks that would otherwise violate the 

border exclusion step have already been disregarded from analysis by the size exclusion step, and are 

thus categorized under size excluded chunks instead of border excluded chunks.  
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Figure 9. Demonstration of PCPA’s plastic wrap feature. (A) Example chunk with no enclosed caves. 

PCPA will draw a bounding box encompassing all pixels of the chunk. (B-D) Example showing plastic 

wrapped pixels (yellow) projecting an exploratory line (red with white dot) from an orphaned pixel 

(coordinates 10, 3). When PCPA finds no chunk pixels that fall within the exploratory line, the next 

exploratory line is drawn from the orphan pixel to the next row of the last column. (E) PCPA will 

continue in the same manner until the exploratory line encounters a white pixel that falls within the 

exploratory line (pink with white dot). (F-G) All pixels of the exploratory line that connect the two pixels 

of the chunk (teal) will be added to the chunk mass for subsequent analyses.  
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Figure 10. (A) When using PCPA on cells lacking a uniform oval shape, using Plastic Wrap (blue outline) 

may cause large caves to form that are the result of the shape distortion and not of inherent cell 

characteristics. (B) Cave selection criteria can be used to select for the user’s cave of interest. If the 

largest cave is selected, PCPA selects the large inclusion created by Plastic Wrap. This can be addressed 

by changing the cave selection to northmost cave, which will disqualify the largest inclusion at the 

bottom of the cell. Alternatively, users can combine the largest cave setting with cave maximum and/or 

minimum size restrictions—here, a maximum size has been applied to exclude the large inclusion on the 

bottom caused by Plastic Wrap.  
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Figure 11. User option menu for PCPA chunk detection. (A) The exclusion criteria box allows users to 

disregard chunks smaller and/or larger than a specified pixel size, and to exclude cells a set pixel 

distance from the image border. (A’) Example output where size excluded chunks are shown as pink 

pseudocoloring and border excluded chunks are shown as blue pseudocoloring. (B) To address instances 

were two chunks touch after applying thresholding, users can set options to split chunks meeting a set 

ratio of wider-than-tall or taller-than-wide, or to exclude these chunks from further analyses. (B’) Subset 

of A’ (green box). If no doublet splitting options are applied, PCPA will treat this chunk as one mass and 

the angle measurements will incorrectly calculate based on the total chunk mass and dominant cave of 

the chunk. When doublet splitting options are applied, PCPA will split the doublet in half. The two 

resulting halves will be treated as independent chunks with chunk and cave centroid calculations being 

based on the mass contained within each respective box. 
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Figure 12. User menu for PCPA cave detection. (A) Users are recommended to apply the Plastic Wrap 

function to their analyses. Plastic Wrap allows PCPA to group pixels that are proximal, but not abutting, 

into the same chunk. (A’) Example images show that when plastic wrap is not applied, chunk 1 selects an 

incorrect cave, and chunk 2 is excluded from analysis for having no cave. When plastic wrap is applied, 

PCPA artificially closes off the open cave and selects the correct cave as the cave of interest. (B) Users 

can set minimum and maximum size requirements for cave of interest selection. (C) Users can set a 

directional requirement for cave of interest selection. Selecting a directional characteristic (e.g. 

northmost) will instruct PCPA to designate the cell’s cave as the largest northmost inclusion. (C’) Users 

can combine directional characteristics with a lower size limit for caves, in order to filter out incidental 

inclusions created by Plastic Wrap, pitting caused by the thresholding process, or large inclusions caused 

by irregular cell shapes.  
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Figure 13. User options for angle measurement calculations. 
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Figure 14. PCPA data output tab. (A) Options for data metrics produced by PCPA. (A’) Example of data 

metrics in A. (A’’) Example of overlay superimposed on original preprocessed image. (B) The overlay 

(and selected overlay information) can be superimposed over the original image for data visualization. 

(C) Optional labels can be viewed on the post-PCPA image. (D) Color coding of the post-PCPA image can 

indicate to the investigator what chunks may have been excluded and why. (E) The Colors tab allows 

users to customize color coding options from D.  
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Figure 15. Cell counting when PCP measurements are not needed. (A) Example of recommended output 

settings when a user only desires to view total cell count. (B) Example of the PCPA cell labels overlaid on 

original image of cochlear IHC. (B’) Annotated PCPA output showing counted cells with labels, non-

counted cells (i.e. lacking a cave; red Pseudocolor), and border excluded cells (blue). (C) The Chunk 

Summary table shows how many cells were analyzed (“Processed Count”), how many cells were 

rejected because they lacked a cave (“Bad Count”), and the “Total Count” value of all recognized chunks. 
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Figure 16. Batch process multiple images as one data set. (A) To batch process multiple images, open 

each image of the batch in ImageJ then select “Measure All Open Images Now” or “Measure All Open 

Images With Options” under the PCPA menu. (B) All output metrics will aggregate the data collected 

from each open image into a combined data set. Summary statistics and a rose diagram for the 

combined data set can be viewed 
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Figure 17. Stand-alone rose diagram function. (A) Users will input their data into the data box (one angle 

per line) then set axis orientation options. Users can customize the rose diagram output and optionally 

view summary statistics by selecting the Angle Summary box. (B) Example output from the standalone 

rose diagram function.  

 

 

 

 

 


